安装phpcms时出现Warning: ob_start(): output handler \'ob_gzhandler\' conflicts with \'zlib

发布时间:2020-02-23 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了安装phpcms时出现Warning: ob_start(): output handler \'ob_gzhandler\' conflicts with \'zlib脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
1、 解决方法一:
打开phpcms/base.php,在第57行,修改如下:

if(pc_base::load_config('system','gzip') && function_exists('ob_gzhandler')) {
    //加上如下这段代码
    ob_end_clean();
    ob_start('ob_gzhandler');
} else {
    ob_start();
}

2、解决方法二:
在install_package/caches/configs/下的system.php中找到gzip,修改如下:

'gzip' => 0,//是否Gzip压缩后输出

 

总结

以上是脚本之家为你收集整理的安装phpcms时出现Warning: ob_start(): output handler \'ob_gzhandler\' conflicts with \'zlib全部内容,希望文章能够帮你解决安装phpcms时出现Warning: ob_start(): output handler \'ob_gzhandler\' conflicts with \'zlib所遇到的程序开发问题。

其他人正在看

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您喜欢交流学习经验,点击链接加入脚本之家官方QQ群:1065694478
标签: