打印与标准输入完全相同的格式

如何解决打印与标准输入完全相同的格式

我是Java的初学者,但遇到了问题。问题说:

给出n个实数字符串的数组s,以降序对其进行排序-但是,等等,还有更多!每个数字的打印格式必须与从stdin读取的格式完全相同,这意味着.1打印为.1,0.1打印为0.1。如果两个数字代表数值上相等的值(例如),则必须按照接收到它们作为输入的相同顺序列出它们。

我编写了以下代码:

'public static void main(String []args){
    //Input
    Scanner sc= new Scanner(System.in);
    int n=sc.nextInt();
    String []s=new String[n+2];
    for(int i=0;i<n;i++){
        s[i]=sc.next();
    }
    sc.close();
    //TypeCasting
    BigDecimal[] deci = new BigDecimal[n];
    for(int i=0;i<n;i++){
        deci[i] =new BigDecimal(s[i]);
    }
    //Write your code here//SelectionSort
    for(int i =0; i<n-1; i++){
        for(int j=i; j<n; j++){
            int minIndex = i;
            if(deci[j].compareTo(deci[minIndex])>0){
                minIndex = j;
            } 
            BigDecimal temp = deci[i];
            deci[i] = deci[minIndex];
            deci[minIndex] = temp;
        }
    }
    for(int i=0;i<n;i++){
        s[i] = (deci[i]).toString();
    }
    //Output
    for(int i=0;i<n;i++)
    {
        System.out.println(s[i]);
    }
}`

Sample Input: 9 -100 50 0 56.6 90 0.12 .12 02.34 000.000
Sample Output: 90 56.6 50 02.34 0.12 .12 0 000.000 -100
My Output: 90 56.6 50 2.34 0.12 0.12 0 0.000 -100

请帮助我如何打印与我上面使用的“选择排序”完全相同的格式。

解决方法

您可以与String[] s同时对BigDecimal[] deci进行排序。这样一来,您就可以输出以System.in形式读取的原始字符串,而不必以某种方式将BigDecimal对象转换回其原始字符串。

您应该注意,您的代码确实实现了选择排序,但是没有实现稳定选择排序。也就是说,“如果两个数字代表数值上相等的值(例如),则必须按照接收到它们作为输入的相同顺序列出它们。”
例如:

Sample Input:  6 .1 1 0.1 10 00.1 2
Expected Output: 10 2 1 .1  0.1 00.1
Your Output:     10 2 1 .1 00.1  0.1

可以通过以下两种方法之一实现稳定的选择排序:使用数组,然后在其索引处插入下一个值,然后移动其余元素。或者使用LinkedList并将下一个值添加到未排序部分的开头。

这是 insert and shift 方法的实现。我只是向左交换deci[]个元素,直到它们在正确的索引中为止,而不是插入并向右移动。

static String[] selectionSortStable(BigDecimal[] deci,String[] s,int n) {
    //Write your code here //SelectionSort
    for(int i = 0; i < n - 1; i++) {
        for(int j = i + 1; j < n; j++) {
            int minIndex = i;
            
            if(deci[j].compareTo(deci[minIndex]) >= 0) {
                minIndex = j;
            } else {
                continue; // don't need to swap already sorted elements
            }
            
            // in order to ensure a stable sort,we need to swap unsorted
            // elements until deci[minIndex] is in deci[i]
            for(int k = minIndex; k > i; k--) {
                BigDecimal bdtmp = deci[k];
                deci[k] = deci[k - 1];
                deci[k - 1] = bdtmp;
                
                // sort the array of string representations at the same time
                String stmp = s[k];
                s[k] = s[k - 1];
                s[k - 1] = stmp;
            }
        }
        
    }
    
    return s;
}

public static void main(String[] args) {
    //Input
    Scanner sc = new Scanner(System.in);
    int n = sc.nextInt();
    String[] s = new String[n+2];
    for(int i = 0; i < n; i++) {
        s[i] = sc.next();
    }
    sc.close();
    //TypeCasting
    BigDecimal[] deci = new BigDecimal[n];
    for(int i = 0; i < n; i++) {
        deci[i] = new BigDecimal(s[i]);
    }
    
    s = selectionSortStable(deci,s,n);

    // now just output the sorted string array 's'
    for(int i = 0; i < n; i++) {
        System.out.print(s[i] + " ");
    }
    
    System.out.println();
}
,
public static void main(String[] args) {
    class Data {

        int order;
        double value;
        String str;
    }

    try (Scanner scan = new Scanner(System.in)) {
        scan.useLocale(Locale.ENGLISH);

        Comparator<Data> sortByValueDescThenByOrderAsc = (one,two) -> {
            int res = Double.compare(two.value,one.value);
            return res == 0 ? Integer.compare(one.order,two.order) : res;
        };

        String[] nums = scan.nextLine().split("\\s+");
        List<Data> res = new ArrayList<>();

        for (int i = 0; i < nums.length; i++) {
            Data data = new Data();
            data.str = nums[i];
            data.order = i;
            data.value = Double.parseDouble(data.str);
            res.add(data);
        }

        res.sort(sortByValueDescThenByOrderAsc);

        System.out.println(res.stream().map(data -> data.str).collect(Collectors.joining(" ")));
    }
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐


依赖报错 idea导入项目后依赖报错,解决方案:https://blog.csdn.net/weixin_42420249/article/details/81191861 依赖版本报错:更换其他版本 无法下载依赖可参考:https://blog.csdn.net/weixin_42628809/a
错误1:代码生成器依赖和mybatis依赖冲突 启动项目时报错如下 2021-12-03 13:33:33.927 ERROR 7228 [ main] o.s.b.d.LoggingFailureAnalysisReporter : *************************** APPL
错误1:gradle项目控制台输出为乱码 # 解决方案:https://blog.csdn.net/weixin_43501566/article/details/112482302 # 在gradle-wrapper.properties 添加以下内容 org.gradle.jvmargs=-Df
错误还原:在查询的过程中,传入的workType为0时,该条件不起作用 &lt;select id=&quot;xxx&quot;&gt; SELECT di.id, di.name, di.work_type, di.updated... &lt;where&gt; &lt;if test=&qu
报错如下,gcc版本太低 ^ server.c:5346:31: 错误:‘struct redisServer’没有名为‘server_cpulist’的成员 redisSetCpuAffinity(server.server_cpulist); ^ server.c: 在函数‘hasActiveC
解决方案1 1、改项目中.idea/workspace.xml配置文件,增加dynamic.classpath参数 2、搜索PropertiesComponent,添加如下 &lt;property name=&quot;dynamic.classpath&quot; value=&quot;tru
删除根组件app.vue中的默认代码后报错:Module Error (from ./node_modules/eslint-loader/index.js): 解决方案:关闭ESlint代码检测,在项目根目录创建vue.config.js,在文件中添加 module.exports = { lin
查看spark默认的python版本 [root@master day27]# pyspark /home/software/spark-2.3.4-bin-hadoop2.7/conf/spark-env.sh: line 2: /usr/local/hadoop/bin/hadoop: No s
使用本地python环境可以成功执行 import pandas as pd import matplotlib.pyplot as plt # 设置字体 plt.rcParams[&#39;font.sans-serif&#39;] = [&#39;SimHei&#39;] # 能正确显示负号 p
错误1:Request method ‘DELETE‘ not supported 错误还原:controller层有一个接口,访问该接口时报错:Request method ‘DELETE‘ not supported 错误原因:没有接收到前端传入的参数,修改为如下 参考 错误2:cannot r
错误1:启动docker镜像时报错:Error response from daemon: driver failed programming external connectivity on endpoint quirky_allen 解决方法:重启docker -&gt; systemctl r
错误1:private field ‘xxx‘ is never assigned 按Altʾnter快捷键,选择第2项 参考:https://blog.csdn.net/shi_hong_fei_hei/article/details/88814070 错误2:启动时报错,不能找到主启动类 #
报错如下,通过源不能下载,最后警告pip需升级版本 Requirement already satisfied: pip in c:\users\ychen\appdata\local\programs\python\python310\lib\site-packages (22.0.4) Coll
错误1:maven打包报错 错误还原:使用maven打包项目时报错如下 [ERROR] Failed to execute goal org.apache.maven.plugins:maven-resources-plugin:3.2.0:resources (default-resources)
错误1:服务调用时报错 服务消费者模块assess通过openFeign调用服务提供者模块hires 如下为服务提供者模块hires的控制层接口 @RestController @RequestMapping(&quot;/hires&quot;) public class FeignControl
错误1:运行项目后报如下错误 解决方案 报错2:Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project sb 解决方案:在pom.
参考 错误原因 过滤器或拦截器在生效时,redisTemplate还没有注入 解决方案:在注入容器时就生效 @Component //项目运行时就注入Spring容器 public class RedisBean { @Resource private RedisTemplate&lt;String
使用vite构建项目报错 C:\Users\ychen\work&gt;npm init @vitejs/app @vitejs/create-app is deprecated, use npm init vite instead C:\Users\ychen\AppData\Local\npm-