赞助商

网络运维面试题

发布时间:2019-04-01 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了网络运维面试题脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。

1.ARP的中文名称及作用?

地址解析协议 将IP转化为MAC地址

2.MAC的广播地址?

FF-FF-FF-FF-FF-FF

3.如何解决ARP欺骗?

PC 和 网关双向绑定MAC 地址

4.总结交换机的工作原理?

学习 广播 转发 单薄

5.交换机和路由器哪个设备转发数据包时会修改MAC地址?为什么要修改?

路由器

当网关路由器接收到以太网数据帧时,发现数据帧中的目标MAC地址是自己的某一个端口的物理地址,

这时路由器会把以太网数据帧的封装去掉。路由器认为这个IP数据包是要通过自己进行转发,

着它就在匹配路由表。匹配到路由项后,它就将包发往下一条地址。

路由器转发数据包不会对它的IP源地址和目标地址做修改,只会修改MAC.

6.TCP/IP五层模型每一层对应的设备分别是什么?

物理层 网卡 数据链路层 交换机 

网络层 路由器 传输层 防火墙 应用层 计算机

7.如何实现交换机之间的VLAN通讯?

单臂路由或者三层交换

8.单臂路由的缺陷是什么?

1.“单臂”为网络骨干链路,容易形成网络瓶颈

2.子接口依然依托于物理接口,应用不灵活

3.VLAN间转发需要查看路由表,严重浪费设备资源

9.CEF包含的两个转发信息表分别是什么?

转发信息库(FIB) 邻接关系表

10.如何将三层交换机的交换接口转换为路由接口?

in f0/0

no switchport

11.如何在三层交换机上启用路由功能?

ip routing

12.配置DHCP中继的命令是什么?

in vlan 10

ip helper-address 1.0.0.1

13.写出路由器配置DHCP的命令及步骤?

(config)#ip dhcp pool pool-name

(dhcp-config)#network network-number mask

(dhcp-config)#default-router gateway-ip

(dhcp-config)#dns-server dns-ip

(dhcp-config)#lease days hours mins

(config)#ip dhcp excluded-address low-address [high-address]

14.简述什么是广播风暴?

广播风暴,当广播数据充斥网络无法处理,并占用大量网络带宽,

导致正常业务不能运行,甚至彻底瘫痪,这就发生了“广播风暴”

15.STP是什么协议?主要作用是什么?

Spanning Tree Protocol(生成树协议)

逻辑上断开环路,防止广播风暴的产生

当线路故障,阻塞接口被激活,恢复通信,起备份线路的作用

16.什么是BPDU?

BPDU是运行STP的交换机之间交换的消息帧。

BPDU内包含了STP所需的路径和优先级信息

17.生成树算法分为哪三个步骤?

选择根网桥 选择根端口 选择指定端口

18.网桥ID的缺省值是多少?

32768

19.网桥ID最大的会成为根网桥还是最小的会成为根网桥?

小的

20.STP路径成本19和路径成本100分别代表的链路带宽是多少?

100Mbps 10Mbps

21.网桥ID占用几个字节?取值范围是多少?

8 0--65535

22.端口ID的缺省值是多少?

128

23.端口ID占用几个字节?取值范围是多少?

2字节 0--255

24.交换机端口的五种STP状态分别是什么?

转发 学习 侦听 阻塞 禁用

25.STP的三种计时器分别是什么?

Hello时间 转发延迟 最大老化时间

26.在VLAN中启用生成树协议的命令是什么?

Switch(config)#spanning-tree vlan vlan-list

27.优先级的值是多少的倍数?

4096

28.使用什么命令查看生成树的配置?

Switch#show spanning-tree

29.简述什么是速端口?速端口的配置命令是什么?

通过速端口,可以大大减少处于侦听和学习状态的时间,

速端口几乎立刻进入转发状态。

速端口将工作站或者服务器连接到网络的时间减至最短

(config-if)#spanning-tree portfast

(config-if)#no spanning-tree portfast(关闭速端口)

30.简述HSRP协议?

HSRP 是 Hot Standby Routing Protocol(热备份路由协议)的缩写。

它的作用是能够把一台或多台路由器用来做备份,所谓热备份是指当使用的路由器

不能正常工作时,候补的路由器能够实现平滑的替换,尽量不被察觉。

31.HSRP协议是开放协议还是私有协议?

思科私有协议

32.HSRP有哪些组成员?

活跃 备份 虚拟 其他

33.ICMP包由ICMP头部和ICMP数据组成,请简述ICMP数据内存放什么数据?

ICMP数据内是ping生成的A-Z和各种符号的垃圾数据,主要用来填充字节

34.HSRP虚拟MAC地址由哪几部分组成?

厂商编号(24位)+虚拟MAC地址(16位)+HSRP组号(8位)

35.所有路由器都会发送或接收HSRP消息,那么HSRP使用哪个端口发送消息?是TCP协议还是UDP协议?

udp 1985

36.同上题,HSRP消息使用哪个组播地址发送?TTL值为多少?

224.0.0.2 1秒

37.HSRP计时器中,Hello间隔和保持时间分别是多少秒?

hello 3秒 保持时间 10秒

38.HSRP的六种状态分别是什么?

初始,学习,监听,

发言,备份,活跃

39.什么是VRRP协议?简述VRRP和HSRP的区别?

虚拟路由器冗余协议

1.在功能上VRRP和HSRP非常相似,但是就安全而言,VRRP对HSRP的一个主要优势:它允许参与VRRP组的设备间建立认证机制.并且不像 HSRP那样要求虚拟路由器不能是其中一个路由器的ip地址,但是VRRP允许这种情况发生,但是为了确保万一失效发生的时候终端主机 不必重新学习MAC地址,它指定使用的MAC地址00-00-5e-00-01-VRID,这里的VRID是虚拟路由器的ID(等价于一个HSRP的组标识符).

2.另外一个不同是VRRP不使用HSRP中的政变或者一个等价消息,VRRP的状态机比HSRP的要简单,HSRP有6个状态 初始 学习 监听 对话 备份 活动 )和8个事件,VRRP只有3个状态(初始状态(Initialize)、主状态(Master)、备份状态(Backup))和5个事件.

3.HSRP有三种报文,而且有三种状态可以发送报文 呼叫(Hello)报文/告辞(Resign)报文/突变(Coup)报文,

VRRP有一种报文,广播报文,由主路由器定时发出来通告它的存在,使用这些报文可以检测虚拟路由器各种参数,还可以用于主路由 器的选举。

4.HSRP将报文承载在UDP报文上,而VRRP承载在TCP报文上(HSRP 使用UDP 1985端口,向组播地址224.0.0.2 发送hello消息。)

5.VRRP的安全:VRRP协议包括三种主要的认证方式:

无认证;简单的明文密码;

使用MD5 

HMAC ip认证的强认证;

6.VRRP的崩溃间隔时间:3*通告间隔+时滞时间(skew-time)

7.hsrp为私有,vrrp不支持接口跟踪机制

40.HSRP的优先级取值范围是多少?默认优先级是多少?

HSRP的优先级取值范围是0-255,默认是100

41.简述HSRP协议中占先权的作用什么?

是当活跃路由器失效或者停止工作的时候;备份路由器将自动承担活跃路由器的角色。

即使当活跃路由器重新工作的时候备份路由器还承载活跃路由器的角色来继续转发路由器

42.配置HSRP协议中占先权的配置命令是什么?

(1)进入接口配置模式:Interface fasternet 0/2

(2)配置占先权: standby 10 ip preempt

43.简述HSRP中什么是端口跟踪?

如果所监测的端口出现故障,则也可以进行路由器的切换。

44.ICMP的全称是什么?它的作用是什么?

ICMP是(Internet Control Message Protocol)Internet控制报文协议

查看网络通不通、主机是否可达、路由是否可用

45.使用什么命令来查看HSRP的详细信息?

Switch#show standby

46.简述IP包头的长度是多少? 包头长度随着什么而改变?

20字节 可选项

47.A,B,C,D,E五类地址中,哪两类地址是无类地址?他们被应用于什么地方?

D 网络中的组播地址(多目广播) 

239.0.0.--239.255.255.254 

E 科研 240.0.0.0--255.255.255.255

48.为什么要进行子网划分?

节约公网IP 体现网络的层次性

49.简述什么是CRC?

循环冗余码校验,它是利用除法及余数的原理来作错误侦测(Error Detecting)的。

实际应用时,发送装置计算出CRC值并随数据一同发送给接收装置,

接收装置对收到的数据重新计算CRC并与收到的CRC相比较,

若两个CRC值不同,则说明数据通讯出现错误。

50.OSI七层模型中,哪一层定义了数据传输的端口号?

传输层

51.简述逻辑运算中的‘与’运算?

1与任何数与运算都的1 0与任和数相与都的0

52.二进制的基数为什么?分别用哪些数值来表示?逢几进一?

0和1 2

53.IP地址由哪两部分组成?

网络部分与主机部分

54.子网掩码的作用是什么?

识别IP属于哪个网络

55.访问控制列表(ACL)有哪三种类型?

标准访问控制列表

基于源IP地址过滤数据包

标准访问控制列表的访问控制列表号是1~99

扩展访问控制列表

基于源IP地址、目的IP地址、指定协议、端口和标志来过滤数据包

扩展访问控制列表的访问控制列表号是100~199

命名访问控制列表

命名访问控制列表允许在标准和扩展访问控制列表中使用名称代替表号

56.什么是TCP协议和UDP协议?区别是什么?

TCP(Transmission Control Protocol 传输控制协议)是一种面向连接的、可靠的、较慢

UDP(User Data Protocol,用户数据报协议)是与TCP相对应的协议。 较快

它是面向非连接的协议,它不与对方建立连接,而是直接就把数据包发送过去!

57.分别写出A,B,C三类地址的私有地址范围?

10.0.0.0 -- 10.255.255.255 

172.16.0.0 -- 172.31.255.255

192.168.0.0--192.168.255.255

58.IP地址中的私有地址可以在互联网中使用吗?为什么?

不行 路由器看私网IP会直接丢包

59.与运算:1与1等于?1与0等于?0与0等于?

1 0 0

60.简述Network Address Translation的作用是什么?

网络地址转换

解决了lP地址不足的问题,

而且还能够有效地避免来自网络外部的攻击,

隐藏并保护网络内部的计算机。

61.计算机如何知道目标IP是否和自己处于同一网段?

IP与子网掩码逻辑与运算

62.不同网段主机之间的通信,数据包将被发送给谁进行转发?

路由器

63.TCP建立连接和终止连接分别需要几次握手?

建立3次 断开4次

64.Cisco设备中,删除访问控制列表ACL的命令是什么?

(config)# no access-list access-list-number

65.访问控制列表的配置思路是什么?

只写允许

66.网络层封装了IP头部,数据链路层封装了MAC头部,那么请问物理层封装了什么?

将二进制封装成比特流

67.简述计算机工作在TCP/IP五层模型的哪一层?为什么?

应用层 应用程序产生数据发送到别的电脑

68.FTP,TELNET,SMTP,HTTP,POP3分别是什么?他们的端口号分别是多少?

文件传输协议 20 21 远程登陆协议 23 简单邮件传输协议 25 

超文本传输协议 80 邮局协议版本3 110

69.UDP报文的首部都存放的有哪些数据?

源端口号 目标端口号 UDP长度 UDP校验和

70.扩展访问控制列表(ACL)通过哪四个元素来对数据包进行过滤?

基于源IP地址、目的IP地址、指定协议、端口和标志

71.将访问控制列表应用在INPUT合理还是应用在OUTPUT合理?为什么?

出公网的应用在input

进私网的应用在output

72.ASA上NAT的实现方式有哪那些?NAT的实现方式有哪些?

ASA上NAT 动态NAT 动态PAT 静态NAT 静态PAT

NAT 静态转换 动态转换 端口多路复用

73.NAT转换中包含了哪四类地址?

内部局部 外部局部 内部全局 外部全局

74.NAT的转换条目有哪两种?

简单转换条目 扩展转换条目

75.NAT的优点以及NAT的缺点分别是什么?

NAT的优点 节省公有合法IP地址

处理地址重叠

增强灵活性

安全性

NAT的缺点

延迟增大

配置和维护的复杂性

不支持某些应用,可以通过静态NAT映射来避免

76.在内部接口和外部接口启用NAT的命令分别是什么?

(config)#interface FastEthernet 0/0

(config-if)#ip nat outside

(config)#interface FastEthernet 1/0

(config-if)#ip nat inside

77.配置默认路由的命令是什么?默认路由的下一跳地址可以使用接口代替吗?

Router(config)#ip route 0.0.0.0 0.0.0.0 下一跳地址/接口

78.企业为什么会在网络边界配置NAT呢?

1、合法的IP地址资源日益短缺

2、一个局域网内部有很多台主机,但不是每台主机都有合法的IP地址,

为了使所有内部主机都可以连接因特网,需要使用地址转换

3、地址转换技术可以有效地隐藏内部局域网中的主机,具有一定的网络安全保护作用

4、地址转换可以在局域网内部提供给外部FTP、WWW、Telnet服务

79.静态NAT,动态NAT,PAT的特点是什么?

静态NAT 一对一

动态NAT 私有IP地址转换为公用IP地址时,IP地址对是不确定的,是随机的,所有被授权访问Internet的私有IP地址可随 机转换为任何指定的合法IP地址 

PAT 多对一

80.使用什么命令查看路由表?如何查看路由协议的配置?

show ip route

show run

81.什么情况下需要使用NAT端口映射?发布服务器

82.简述什么是RIP水平分割?

执行水平分割可以阻止路由环路的发生

从一个接口学习到路由信息,不再从这个接口发送出去

同时也能减少路由更新信息占用的链路带宽资源

83.在清除NAT转换条目时,静态NAT条目会被清除吗?

不会

84.OSPF网络LSA使用类型几的链路状态通告? 

Type 2

85.Debug ip nat命令的作用是什么?

查看NAT 地址转换的包信息

86.什么是动态路由?动态路由的特点是什么?

动态路由指路由器能够自动地建立自己的路由表,

并且能够根据实际情况的变化适时地进行调整

减少了管理任务 占用了网络带宽

87.动态路由的度量值有哪些?

跳数、带宽、负载、时延、可靠性、成本

88.动态路由协议中的收敛指的是什么意思?

使所有路由表都达到一致状态的过程

89.简述什么是距离矢量路由协议和链路状态协议?

距离矢量路由协议 

依据从源网络到目标网络所经过的路由器的个数选择路由 RIP、IGRP

链路状态路由协议

综合考虑从源网络到目标网络的各条路径的情况选择路由 OSPF、IS-IS

91.RIP路由协议的度量值是什么?最大值为多少?超过最大值后会怎么样?

跳数 最大跳数为15跳,16跳为不可达

92.RIP每隔多少秒发送路由更新信息?使用TCP还是UDP的哪个端口发送?

每隔30s发送路由更新消息,UDP520端口

93.简述什么是路由环路?如何产生的?

数据包不停在网络上循环发送

维护路由表信息的时候,如果在拓扑发生改变后,

网络收敛缓慢产生了不协调或者矛盾的路有选择条目,

就会发生路由环路的问题,这种条件下,路由器对无法到达的网络路由不予理睬,

导致用户的数据包不停在网络上循环发送,最终造成网络资源的严重浪费

94.简述OSPF中的虚链路?

指一条通过一个非骨干区域连接到骨干区域的链路

95.IPPV6相对于IPV4最主要的优点是什么?

更大的地址空间

更高效的路由基础 更好的安全型

移动性 更好的QoS

96.多台路由器同时启用RIP路由协议会产生路由环路吗?如果会怎么解决?

会 执行水平分割

97.在输入完router rip命令后,使用什么命令来宣告主网络号?

Router(config-router)# network 网段

98.分别写出直连路由,默认路由,RIP,OSPF,静态路由的优先级?

直连路由 0

默认路由 255

RIP 120

OSPF 1

静态路由 1

99.RIP协议版本,v1和v2有什么区别?

v1 有类路由协议

广播更新 255.255.255.255

不支持VLSM(可变长子网掩码)

自动路由汇总不可以关闭

连续的子网

v2 无类路由协议

组播更新 224.0.0.9

支持VLSM

自动路由汇总可以关闭,可以手工汇总

支持不连续的子网

100.IPV4以及IPV6他们的本地回环地址分别是什么?

IPV4 127网段

IPV6 ::1

101.OSPF中AS外部LSA使用类型几的链路状态通告哦?

Type 5

102.如何启用rip v2版本?

router rip 

version 2

103.OSPF完全末梢区域只有LSA类型为什么通告?

Type 1和Type 2

104.AS,IGP,EGP,BGP分别是什么?

自治系统(autonomous system,AS)

内部网关协议interior gateway protocol 缩写为IGP

外部网关协议exterior gateway protocol 缩写为EGP

边界网关协议Border gateway Protocol 缩写为BGP

105.简述OSPF中Router ID是什么?

OSPF区域内唯一标识路由器的IP地址

106.OSPF的组播地址分别是哪两个?

224.0.0.5 224.0.0.6

107.OSPF将网络划分为了哪四种类型?

点到点网络

广播多路访问网络(

非广播多路访问网络

点到多点网络

108.为什么要使用OSPF多区域?

1、在大型网络中,网络结构的变化是时常发生的,因此OSPF路由器就会经常运行SPF算法来重新计算路由信息,大量消耗路由器的CPU和内存资源。

2、在OSPF网络中,随着多条路径的增加,路由表变得越来越庞大,每一次路径的改变都使路由器不得不花大量的时间和资源去重新计算路由表,路由器越来越低效。

3、包含完整网络结构的链路状态数据库也会越来越大,这将有可能使路由器的CPU和内存资源彻底耗尽,从而导致路由器的崩溃。

然后,通过OSPF划分区域以便引出OSPF多区域划分的原因

改善网络的可扩展性 

快速收敛

109.OSPF中的Router ID选取规则是什么?

首先,选取路由器loopback接口上数值最高的IP地址

如果没有loopback接口,在物理端口中选取IP地址最高的

也可以使用router-id命令指定Router ID

110.什么是Qos,使用Qos的目的是什么?

服务质量

区分流量,保证重要流量及时被转发

111.路由器LSA使用类型为几的链路状态通告?

Type 1

112.Clear ip route命令的作用是什么?

清除路由表

113.如何只查看OSPF学习到的路由信息?

show ip route ospf

114.OSPPF中,选择路由条目的依据是什么?

管理距离 度量值

115.OSPF末梢区域中没有LSA类型为几的通告?(共三个)

Type 4 Type 5 Type 7

116.路由重分发需要考虑哪些因素?

度量值 管理距离

117.OSPF地址汇总的作用是什么?

地址汇总是通过减少泛洪的LSA数量节省资源,说白了就是节省路由器计算路由表的资源和时间。

还可以通过屏蔽一些网络不稳定的细节来节省资源。

118.IPV6中存在分片的概念吗?为什么?

不分片 采用路径MTU发现机制,整个链路使用最小MTU发送数据

119.简述 IPV6中的链路本地地址?

每个设备的接口在启动IPv6的时候会自动配置一个链路本地地址

IPv6的“邻居发现”机制要用到IPv6的链路本地地址

链路本地地址以“FE80”开头

Interface ID是通过EUI-64自动生成

路由器绝不会转发链路本地地址

120.ping 127.1命令是否成立?如果成立ping的完整IP是什么?

成立 127.0.0.1

121.没有Qos的网络中会出现什么问题?

延迟、延迟抖动、丢包

122.简述Qos中的尽力而为的服务模型?

先进先出的转发

网络尽最大的可能性来发送报文,但对时延、可靠性等性能不提供任何保证,

因此它也是最简单的服务模型。

123.简述Qos中综合服务模型?

提前申请网络资源,各节点预留资源

124.简述Qos中的区分服务模型?

不预留资源,分类和排队机制,为数据流提供比其他数据流有限级更高的服务

125.Qos中的GTS是什么?GTS只能应用在input方向还是output方向?

流量整形 是一种调节输出速率的措施,流量整形使用缓冲区使流量均匀的进行转发。

由于流量整形使用缓存来保存违规流量,所以可以减小丢包率,避免了报文重发,但是使用缓存将导致数据转发时增加时延。流量整形一般应用在整体流量较小,但有时出现突发流量的环境。

GTS只能应用在output方向,CAR可以应用在两个方向。

承诺访问速率(CAR)

126.简述Qos中的加权公平队列(WFQ)

将需要转发的数据按照调度顺序进行转发。 

WFQ对数据进行分流,尽量将不同的流量分入不同的队列,以整体上均衡各个流的时延。

在出队的时候,WFQ按照流的优先级来分配出口的带宽,优先级越小得到的带宽越小,

优先级越大所得到的带宽越大

127.CAR与GTS的区别是什么?

1 GTS使用缓存减少对比,增加了时延;

2 CAR直接丢弃数据包,保证了时延,增加了丢包率。

(CAR技术限制流量速率时,违规流量一般会被直接被丢弃,

所以CAR技术保证了数据的时延,但是增加了丢包率。

CAR技术多应用于接入层对接入用户经行流量限制。)

 

128.硬件防火墙和软件防火墙区别是什么?

硬件防火墙 

功能少 效率高 稳定性高 服务器CPU占用率为0 

售后服务好 配置略为复杂 防范控制高四层 抗攻击能力强

软件防火墙 

功能多 效率较低 稳定性低 占用CUP 

售后服务一般 配置简单 防范控制下三层 抗攻击能力一般

129.防火墙一般工作在OSI七层参考模型的第几层?为什么?

目前的硬件防火墙可以在第二层至第七层工作,

即可以做链路层访问控制(MAC)到应用层访问控制(关键字过滤等)

130.Cisco的ASA防火墙属于硬件防火墙还是软件防火墙? 硬件防火墙

131.对数据包进行出站入站检测,并进行行为预判,当发现入侵的行为时就会向管理员报警的设备是? 防火墙

132.华为的路由交换设备配置方法是否与cisco的设备相同?为什么?

就是配置命令有区别,,原理都一样,,毕竟华为是抄袭思科的过来的。。。。呵呵

133.状态化防火墙维护一个关于用户信息的连接表-Conn,那么Conn表中关键信息有哪些?

源IP地址

目的IP地址

IP协议(例如TCP或UDP)

IP协议信息(例如TCP/UDP端口号,TCP序列号,TCP控制位)

134.ICMP协议是状态化的还是非状态化的?

默认情况下,ASA对TCP和UDP协议提供状态化连接,但ICMP协议是非状态化的

135.ASA防火墙使用安全算法实现了哪三种基本操作?

访问控制列表 基于特定的网络、主机和服务(TCP/UDP端口号)控制网络访问

连接表 维护每个连接的状态信息,安全算法使用此信息在已建立的连接中有效转发流量

检测引擎: 执行状态检测和应用层检测,检测规则集是预先定义的,来验证应用是否遵从每个RFC和其他标准

136.ASA防火墙有两种接口名称,分别是物理名称以及逻辑名称,

那么逻辑名称中包含了哪些名称来描述安全区域?

inside、 outside

137.接口安全级别大的可以访问接口安全级别低的,那么如果两个接口的安全级别相同会怎么样?

默认情况下,相同安全级别接口之间不允许通信,可以使用以下命令:

#same-security-traffic permit interface //允许相同安全级别接口之间互相通信。

138.Outside是否可以以访问inside接口?为什么?那么inside是否可以访问outside接口?

较高安全接口访问较低安全接口:允许所有基于IP的数据流通过,除非有ACL访问控制列表,认证或授权的限制。

较低安全接口访问较高安全接口:除非有conduit或acl进行明确的许可,否则丢弃所有的数据包。

默认外网接口为 0/0 安全级别默认为 0

内网接口为 0/1 安全级别默认为 100 

dmz 接口为 0/2 安全级别默认为 50

139.当一台没有任何配置的新ASA防火墙,我们应该如何对其进行配置?

console

140.ASA支持哪几种远程连接协议? 

s

telnet ssh asdm (自适应安全设备管理器)

总结

以上是脚本之家为你收集整理的网络运维面试题全部内容,希望文章能够帮你解决网络运维面试题所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:76874919,请注明来意。