如何在win7 x64上使用带有php(xampp)的oracle客户端11.2

发布时间:2020-09-15 发布网站:编程之家
编程之家收集整理的这篇文章主要介绍了如何在win7 x64上使用带有php(xampp)的oracle客户端11.2编程之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
我刚刚在我的win7(x64)PC上安装了一个真正的XAMPP来编写一些 PHP脚本来连接到oracle DB.我也安装了一个普通的oracle 11.2.0客户端(正确设置了PATH和ORACLE_HOME).客户端用于我的所有其他工作没有任何问题.

当我尝试连接到oracle数据库时,PHP失败并出现致命错误:调用未定义的函数oci_connect().我记得在几年前我做同样的事情时我必须在我的php.ini中启用“oci8-extensions”在x32 winXP PC上.
但是我当前的xampp在php / ext文件夹中没有这些dll(只有一个php_oci8_12c.dll在apache启动时抛出了几个未知函数的错误,而且是针对oracle 12而不是11)并且php.ini也说它们是只需要即时客户端.

;extension=php_oci8.dll      ; Use with Oracle 10gR2 Instant Client
;extension=php_oci8_11g.dll  ; Use with Oracle 11gR2 Instant Client

SO-questions也显示使用普通客户端的评论扩展名不起作用(我也尝试过).

我试图谷歌寻求解决方案,但所有“解决方案”都是“安装win32即时客户端并启用扩展”.但我不能这样做,因为我的大多数QA工作需要安装和配置的11.2.0客户端,而且我的php / ext文件夹中没有.dll

我还尝试将ociw32.dll从client / bin文件夹复制到php / ext-folder,但后来apache说它不是PHP库.

那么如何启用PHP oracle库在x64 win7上使用oci8 for XAMPP而无需安装win32 Oracle Instant Client并破坏我当前的设置?

编辑:我也尝试了in the PHP: Installation Manual (Post of: samantha dot vincent at gmail dot com)所描述的步骤,包括更改我的apache-http.conf,这也没有帮助.

我也对我的phpinfo()感到困惑 – 正如它所说的那样

Configure Command   "--with-pdo-oci=c:\php-sdk\oracle\x86\instantclient_12_1\sdk,shared" "--with-oci8-12c=c:\php-sdk\oracle\x86\instantclient_12_1\sdk,shared"

解决方法

我终于找到了解决方案:

我从“PECL :: PAckage :: oci8 :: 2.0.8”下载了实际的OCI-DLL(在我的例子中是32位,线程安全的DLL),然后删除了;从这条线

;extension=php_oci8_11g.dll  ; Use with Oracle 11gR2 Instant Client

我还在apache的http.conf中添加了以下行

SetEnv ORACLE_BASE "C:/oracle/"
SetEnv ORACLE_HOME "C:/oracle/product/11.2.0/client_1"

之后我重新启动了apache,确保我的连接别名可能放在我的tsnames.ora中然后我可以使用oci8函数来解决任何问题.

总结

以上是编程之家为你收集整理的如何在win7 x64上使用带有php(xampp)的oracle客户端11.2全部内容,希望文章能够帮你解决如何在win7 x64上使用带有php(xampp)的oracle客户端11.2所遇到的程序开发问题。

如果觉得编程之家网站内容还不错,欢迎将编程之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您喜欢交流学习经验,点击链接加入编程之家官方QQ群:1065694478
编程之家官方公众号

微信公众号搜索 “ 程序精选 ” ,选择关注!

微信公众号搜索 “ 程序精选 ”
精选程序员所需精品干货内容!