赞助商

ri有空的文档 – Ubuntu 11.10,Ruby 1.9

发布时间:2019-06-11 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了ri有空的文档 – Ubuntu 11.10,Ruby 1.9脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
我正在运行Ubuntu 11.10并安装了 Ruby 1.9,如下所示:
$sudo apt-get install ruby1.9 rubygems

一切都很好,但ri似乎有空文件. ri告诉我,文件是空的,我不得不安装它们.我执行此操作是因为我读到它会有所帮助:

$rdoc --all --ri

现在,当我尝试打开任何文档时:

$ri Array
Nothing known about Array

我搜索的其他内容也是如此.

解决方法

那这个呢 ?
apt-get install ri1.8

编辑

或试试这个:(非rvm)

gem install rdoc rdoc-data
rdoc-data --install

总结

以上是脚本之家为你收集整理的ri有空的文档 – Ubuntu 11.10,Ruby 1.9全部内容,希望文章能够帮你解决ri有空的文档 – Ubuntu 11.10,Ruby 1.9所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:76874919,请注明来意。
标签: