RVM安装和使用总结笔记

发布时间:2019-04-18 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了RVM安装和使用总结笔记脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。

安装RVM命令:

复制代码 代码如下:

然后修改用户配置文件/Users/username/.profile,你也可以写到别的全局配置里.

添加一行代码:

复制代码 代码如下:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"  # This loads RVM into a shell session.

如果"$HOME/.rvm/scripts/rvm" 存在,则执行

重启Terminal,RVM就安装好了. RVM的使用过程中不需要使用sudo,gem也不需要.

然后就可以安装ruby了,例如:

复制代码 代码如下:

rvm install ruby-1.8.7 --head --docs
--docs是编译安装后自动生成文档,--head是最新的版本

删除某个版本的ruby,并且把文档和gems都删除,则:
复制代码 代码如下:

rvm remove ruby-1.8.7 --docs --gems

选择版本:

复制代码 代码如下:

rvm use ruby-1.8.7 --default

查询当前版本:
复制代码 代码如下:

rvm info

列出版本:

复制代码 代码如下:

rvm list

rvm除了可以管理不同的ruby版本外,还可以为每个ruby版本创建不同的Gem集合(gemsets),从而使不同的Ruby应用可以独立使用自己的Gem集合。比如在使用ruby-1.9.2-p290的情况下,我需要建立两个rails工程,一个使用rails-3.0,一个使用rails-3.1.0,我们便可创建两个gemset,并在各个gemset下分别安装对应的rails版本和所需其他Gem:
复制代码 代码如下:

     rvm gemset create rails-3.0            #创建名为rails-3.0的gemset
     rvm 1.9.2-p290@rails-3.0               #使用ruby-1.9.2-p290并使用rails-3.0 gemset
     gem install rails -v 3.0                    #在rails-3.0 gemset下安装rails的3.0版本
     rvm gemset create rails-3.1.0         #创建名为rails-3.1.0的gemset
     rvm 1.9.2-p290@rails-3.1.0            #使用ruby-1.9.2-p290并使用rails-3.1.0 gemset
     gem install rails -v 3.1.0                 #在rails-3.0 gemset下安装rails的3.1.0版本

更多命令,访问 http://rvm.beginrescueend.com/rvm/

总结

以上是脚本之家为你收集整理的RVM安装和使用总结笔记全部内容,希望文章能够帮你解决RVM安装和使用总结笔记所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:76874919,请注明来意。

脚本之家官方公众号

微信公众号搜索 “ 程序精选 ” ,选择关注!

微信公众号搜索 “ 程序精选 ” ,选择关注!
精选程序员所需精品干货内容!

标签: