Metasploit Framework 安装失败pgsql could not connect 7337 10061

发布时间:2020-06-01 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了Metasploit Framework 安装失败pgsql could not connect 7337 10061脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
Q:

在中文Win7上安装Metasploit Framework 3.5.2失败,错误类似:

Error running C:\Program Files\Rapid7\framework/postgresql/bin/psql.exe -U postgres -p 7175 -h localhost -c "ALTER USER postgres PASSWORD '1aeed8e3'"

could not connect to server: Connection refused (0x0000274D/10061)

用TCPView查看,发现没有进程侦听7175/TCP,而上述命令显然需要连接此端口。看
上去是framework-3.5.2.exe在执行过程中没有正确启动数据库服务。

A: HD Moore <hdm@digitaloffense.net> 2010-11-29

在非英文Windows上安装Metasploit Framework 3.5.2时会碰上此问题。PostgreSQL
的缺省locale与SQL_ASCII语句不兼容。

可以"控制面板->区域和语言->格式->英语(美国)",然后执行framework-3.5.2.exe。
安装结束后再改回"中文(简体,中国)"。

总结

以上是脚本之家为你收集整理的Metasploit Framework 安装失败pgsql could not connect 7337 10061全部内容,希望文章能够帮你解决Metasploit Framework 安装失败pgsql could not connect 7337 10061所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您喜欢交流学习经验,点击链接加入脚本之家官方QQ群:1065694478