postgresql – 为postgres Ubuntu安装pdo

发布时间:2020-07-04 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了postgresql – 为postgres Ubuntu安装pdo脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
我试图启用pdo驱动程序为我的php安装,但当我runn命令
./configure --prefix=/usr/local/webserver/php --with-apxs2=/usr/local/webserver/apache2/bin/apxs --enable-mbstring --enable-intl --with-icu-dir=/usr --with-pgsql=/usr/local/webserver/postgres --with-pdo-pgsql=/usr/local/webserver/postgres

我得到

"Unable to build the PDO PostgreSQL driver: libpq 7.4+ is required"

我在该目录中安装postgresql

/usr/local/webserver/postgres

我安装postgresql 9.0.4.1使用bin包和使用php 5.3

Pecl PDO包现已废弃。顺便说一下,debian软件包php5-pgsql现在包括常规和PDO驱动程序,所以只是:
apt-get install php5-pgsql

总结

以上是脚本之家为你收集整理的postgresql – 为postgres Ubuntu安装pdo全部内容,希望文章能够帮你解决postgresql – 为postgres Ubuntu安装pdo所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您喜欢交流学习经验,点击链接加入脚本之家官方QQ群:1065694478
脚本之家官方公众号

微信公众号搜索 “ 程序精选 ” ,选择关注!

微信公众号搜索 “ 程序精选 ”
精选程序员所需精品干货内容!