赞助商

Tell Composer使用不同的PHP版本

发布时间:2019-07-11 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了Tell Composer使用不同的PHP版本脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。

我已经被困在这几天了.我正在使用1and1托管,他们的PHP设置有点奇怪.

如果我只使用php composer.phar安装,那么我使用PHP 4.4.6,这是非常不足够的.但是,我可以运行php5.5 composer.phar安装,稍微进一步,但它仍然失败,因为在某个地方,PHP再次被调用,但它失败了,因为它使用4.4.6.

有没有办法告诉Composer使用php5.5命令?有没有人成功地在1and1主机上配置了Composer?

我正在努力让Laravel启动并运行(使用Composer).我已经能够在我的GoDaddy域上执行此操作,但不能执行1and1.

最佳答案
在xubuntu上我默认使用php 7.2.但是需要用php 5.6运行composer.

所以这对我有用:

php5.6 /usr/bin/composer

总结

以上是脚本之家为你收集整理的Tell Composer使用不同的PHP版本全部内容,希望文章能够帮你解决Tell Composer使用不同的PHP版本所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:76874919,请注明来意。
标签:composer-php