iOS项目要我升级汇编程序codgen和调试器

发布时间:2020-03-26 发布网站:脚本之家
脚本之家收集整理的这篇文章主要介绍了iOS项目要我升级汇编程序codgen和调试器脚本之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
我刚刚更新到xCode 4.3.2.构建调试器时,我希望升级到:
构建设置

目标’myApp’ – 将ARMV6汇编程序代码从THUMB升级到ARM模式
ARMV6汇编程序codegen设置为THUMB.这会将ARMV6的codgen设置升级到建议值:ARM.

Scheme’myApp’ – 将调试器从GDB升级到LLDB
调试器设置为GDB以执行“运行”操作.这会将调试器设置升级到建议值:LLDB.

我可以这样做吗?我的应用程序面向iOS 3.1及更高版本.

解决方法

LLDB有其优势,但恕我直言并不像GDB那样稳定.在大多数情况下,LLDB很好并且可以正常工作.当调试时发生奇怪的事情时,只需在Scheme设置中切换回GDB.所以接受这个升级就好了.

在ARMV6上创建ARM而不是THUMB代码基本上是针对LLVM中的错误(Apple现在更喜欢的Objective-c编译器)的解决方法.如果您不接受此更改,则很可能会错误地优化ARMV6目标代码,从而将问题呈现在您不期望的应用程序中.为了清楚说明,ARMV6 Thumb优化在LLVM 3.1中是错误的(与Xcode 4.3.2及更低版本捆绑在一起).因此,接受此升级是恕我直言.

总结

以上是脚本之家为你收集整理的iOS项目要我升级汇编程序codgen和调试器全部内容,希望文章能够帮你解决iOS项目要我升级汇编程序codgen和调试器所遇到的程序开发问题。

如果觉得脚本之家网站内容还不错,欢迎将脚本之家网站推荐给程序员好友。

其他人正在看

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您喜欢交流学习经验,点击链接加入脚本之家官方QQ群:1065694478

脚本之家官方公众号

微信公众号搜索 “ 程序精选 ” ,选择关注!

微信公众号搜索 “ 程序精选 ” ,选择关注!
精选程序员所需精品干货内容!

标签: