我无法将 function_tree 导入到我的 pubspec.yaml(flutter)

如何解决我无法将 function_tree 导入到我的 pubspec.yaml(flutter)?

开发过程中遇到我无法将 function_tree 导入到我的 pubspec.yaml(flutter)的问题如何解决?下面主要结合日常开发的经验,给出你关于我无法将 function_tree 导入到我的 pubspec.yaml(flutter)的解决方法建议,希望对你解决我无法将 function_tree 导入到我的 pubspec.yaml(flutter)有所启发或帮助;

问题描述

当我尝试将这个包导入我的 my-new-run-mean 时出现错误,我不知道为什么会这样。你能帮我吗?

错误

pubspec.yaml

解决方法

嗨,我认为这是因为版本 >=0.8.0-dev.1 中的 function_tree 支持空安全,而您拥有的 dart 版本尚不支持空安全,因此您有两个选择

第一个是导入0.7.0以下版本的function_tree

第二个是升级flutter,它将支持空安全并更新您的项目,现在您可以使用任何您需要的版本

编程问答问答

在 CSS 中设置 cellpadding 和 cellspacing?
如何在 Java 中创建内存泄漏?
浮点数被破坏了吗?
按字符串属性值对对象数组进行排序
如何加快Android模拟器的速度?
如何舍入至多 2 位小数?
使用 Git 版本控制查看文件的更改历史记录
如何在 JavaScript 中检查空/未定义/空字符串?
微信公众号搜索 “ 程序精选 ” ,选择关注!
微信公众号搜 "程序精选"关注